web.deuxfleurs.fr/shell.nix
2025-04-06 14:57:41 +02:00

11 lines
519 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

let pkgs = import <nixpkgs> {};
in (pkgs.buildFHSUserEnv {
name = "FHS";
targetPkgs = pkgs: [
pkgs.python3
pkgs.uv
pkgs.cairo
]; # Packages to be installed for the main hosts architecture (i.e. x86_64 on x86_64 installations). Along with libraries binaries are also installed.
multiPkgs = pkgs: [ ]; # Packages to be installed for all architectures supported by a host (i.e. i686 and x86_64 on x86_64 installations). Only libraries are installed by default.
runScript = "bash";
}).env